¿Supiste lo que acaba de lanzar LagriHost? Sí, como lo estabas esperando, ahora vendemos Web Hosting y Dominios. Conoce más :)


Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
TUTORIAL 8.- Programación: Estructura de selección, Si, entonces Sino
#1
0
Estructura de selección Si, entonces, Sino

Cuando escribimos un programa muchas veces debemos escribir la solución de modo que tome una decisión, dos o varias, la estructura que vamos a analizar esta vez, es si, entonces, sino, la cual puede utilizarse de 3 formas:
  1. Si, entonces, simple.
  2. Si, entonces, Sino, doble.
  3. Si, entonces, Sino, múltiple.
Si, entonces

La estructura simple de si, evalúa una expresión, que al ser verdadera puede modificar la dirección del programa y si la expresión declarada en si, no es verdadera, el programa simplemente, omite esa dirección y continua la ejecución como si no existiera el si. Veamos como ejemplo el siguiente algoritmo.

Código:
NOTA_APROBACION

{Programa que permite el ingreso de una calificación (nota),
si la nota es mayor o igual a 6, indicara que ha aprobado}

{la variable cali es de tipo entero}

//Suponemos que la calificación siempre es un numero entero, no decimal.

IniciaPrograma
    ESCRIBIR “Verificador de aprobación de prueba”
    ESCRIBIR “Ingresa la calificación obtenida”
    LEER cali
    Si cali >= 6 entonces
        ESCRIBIR “El alumno ha aprobado”
    FinSi
FinPrograma

En cuanto a Pseint puedes observar en la barra derecha de etiquetas, que hay un botón Si, entonces, al presionarlo, te aparece la estructura completa doble, si, entonces, sino, finsi, si fuera requerida solo la estructura simple, debemos borrar las palabras, sino y el rectángulo expresión que lo acompaña.

Si, entonces, Sino

En este caso, la diferencia es que la selección permite elegir entre dos rutas distintas, que ruta seguirá el programa, dependerá de si se cumple o no una condición. Para comprenderlo mejor, continuaremos con el ejemplo anterior, ahora el programa va a evaluar si la nota es mayor o igual a 6 y mostrara aprobado, de lo contrario mostrar reprobado, a continuación el pseudocodigo:

Código:
APROBACION_REPROBADO

{Programa que permite el ingreso de una calificación, si la calificacion es
mayor o igual a 6, indicara que ha aprobado, de lo contrario indicara que ha
reprobado}

{la variable cali es de tipo entero}

//Suponemos que la calificación siempre es un numero entero, no decimal.

IniciaPrograma
    ESCRIBIR “Verificador de aprobación de prueba”
    ESCRIBIR “Ingresa la calificación obtenida”
    LEER cali
    Si cali >= 6 entonces
        ESCRIBIR “El alumno ha aprobado”
    Sino
        ESCRIBIR “El alumno ha reprobado”
    FinSi
FinPrograma

Como pueden observar, este algoritmo evalúa la calificación y la estructura de selección decide si el alumno ha aprobado o reprobado y muestra el resultado en pantalla.

Algo muy importante es, que deben notar, que en las estructuras de selección a las instrucciones que van dentro de estas estructuras he agregado tabulación, esto se hace para que el pseudocodigo sea mas claro, practica que se usa igual en los lenguajes de programación.

Si, entonces, Sino múltiple

En cuanto a esta estructura de selección múltiple, se refiere a que podemos usar el si, entonces, sino, en cascada o anidadas, una dentro de otra. En ocasiones un programa debe tomar varias decisiones sucesivas, o por ejemplo si tenemos mas de un camino a seguir, podemos usar un si en cascada para tomar esas decisiones.

Mejor veamos un ejemplo para dejarlo mas claro, supongamos que en una tienda, se hacen descuentos según el monto de la compra, por ejemplo, si gastamos $200 – $250, descontamos el 10%, si gastamos $300 – $350, descontamos el 15%, si gastamos $500 – $1000, descontamos 20% y si gastamos mas de $2000 o mas, se descontara 25%, a continuación el algoritmo en pseudocodigo:

Código:
DESCUENTO_COMPRA

{Algoritmo que calcula descuento en compra dependiendo la cantidad gastada}

{gasto y descuento, son variables de tipo real}

InicioPrograma
    ESCRIBIR “Calculo de descuento según gasto”
    ESCRIBIR “Ingresar gasto de cliente: “    
    LEER gasto
    Si gasto >= 200 y gasto <= 250 entonces
        HACER descuento <- gasto – (gasto*0,1)
        ESCRIBIR “El descuento es de “, descuento

    Sino
        Si gasto >= 300 y gasto <= 350 entonces
            HACER descuento <- gasto – (gasto*0,15)
            ESCRIBIR “El descuento es de “, descuento
        Sino
            Si gasto >= 500 y gasto <= 1000 entonces
                HACER descuento <- gasto – (gasto*0,20)
                ESCRIBIR “El descuento es de “, descuento
            Sino
                Si gasto >= 2000 entonces
                    HACER descuento <- gasto – (gasto*0,25)
                    ESCRIBIR “El descuento es de “, descuento
                Sino
                    Escribir “No hay descuento”

                Finsi
            Finsi
        Finsi
    Finsi
FinPrograma

Les dejo una imagen de pseint, solo de este algoritmo, les queda de tarea escribir los algoritmos anteriores en pseint.

[Imagen: descuento_compra.png]

El uso de este selector, es bastante sencillo, lo que se debe cuidar bien es la lógica al momento de hacer el algoritmo, porque si el algoritmo se ha hecho correctamente, entonces al momento de probarlo en pseint o trasladarlo a un lenguaje de programación, igualmente no tendrá errores.

En cuanto al pseudocodigo creo que no hay mucho problema, cualquier duda pregunten aquí mismo, igual alguna duda de pseint.
Nunca consideres el estudio como una obligación, sino como una oportunidad para penetrar en el bello y maravilloso mundo del saber. Albert Einstein

No olvides visitar mi web sobre informática... Bitácora Informática

Una nueva comunidad, un nuevo concepto, te esperamos... Tangaria

#2
0
A mí me sigue fascinando que exista ese programa, que puedas trabajar con código en español y puedas ver el programa corriendo... simplemente fascinante.

Aproveché de actualizar el índice general con este capítulo. Guiño

#3
0
(22-08-2014, 01:46 AM)Dark escribió: A mí me sigue fascinando que exista ese programa, que puedas trabajar con código en español y puedas ver el programa corriendo... simplemente fascinante.

Aproveché de actualizar el índice general con este capítulo. Guiño

Si @Dark es realmente útil, ya que te permite introducirte en la programación de una manera sencilla, antes de entrar en código.
Nunca consideres el estudio como una obligación, sino como una oportunidad para penetrar en el bello y maravilloso mundo del saber. Albert Einstein

No olvides visitar mi web sobre informática... Bitácora Informática

Una nueva comunidad, un nuevo concepto, te esperamos... Tangaria



Posibles temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Tutorial [Diseño Web] 1.- Estructura Básica Eloy 12 1,697 22-08-2014, 01:42 AM
Último mensaje: Dark
  Tutorial 7.- Programación: Verificando algoritmos con Pseint Samo30 6 1,413 17-08-2014, 02:30 AM
Último mensaje: Samo30
  Tutorial 6.- Programación: Asignaciones y desarrollo del primer algoritmo Samo30 19 4,560 16-08-2014, 11:45 PM
Último mensaje: Dark
  Tutorial 5.- Programación: Constantes, variables y operadores Samo30 4 844 15-08-2014, 03:03 AM
Último mensaje: Samo30
  Tutorial 4.- Programación: Tipos de datos en algoritmos Samo30 3 637 14-08-2014, 11:33 PM
Último mensaje: Eloy



Usuarios navegando en este tema:
1 invitado(s)


Forum software by © MyBB Theme © Kevinex & iAndrew 2018