¿Supiste lo que acaba de lanzar LagriHost? Sí, como lo estabas esperando, ahora vendemos Web Hosting y Dominios. Conoce más :)


Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA Como habilitar Extension Oci8 PHP
Usuario de cPanel
Dominio
Tipo de Plan
#1
Solucionado
0
Buenas,

Estoy realizando un proyectico en php + Oracle (servidor propio) ya funciona bien y tengo habilitados las dll de Oci8

Código:
;extension=php_oci8.dll
;extension=php_oci8_11g.dll

Pero me gustaría saber si puedo habilitar este modulo y como podría hacerlo en el servidor de LagriHost

Lo que busco es un servidor Apache para montar la WEB y la conexion a la Base de datos se hace en mi servidor Oracle


Muchas Gracias!

#2
Solucionado
0
Hola.

Exactamente para que necesitas esa extensión? Solo nosotros podemos habilitarla, pero queremos saber para que uso lo necesitas y nosotros veremos si es adecuado habilitarlo o no, para la conexión a la base de datos lo podrías hacer de manera remota en todo caso.

Saludos.
Reglas de LagriHost | WIKI/Ayuda-FAQ | Nuestro Equipo | Solicita tu Hosting en 7 Pasos
No doy soporte por MP! Para eso esta el foro Guiño


[Imagen: banner-colabora.gif][Imagen: 8mt2wBp.jpg]

#3
Solucionado
0
  • La conexión a la BD no es el problema yo simplemente escribo el nombre del sevidor y demas datos y ya me conecto.
  • Lo que pasa es que las consultas y la conexión que se hacen en php son de Oracle, entonces se necesita el driver para que sirvan las funciones SQL, 
  • Igualmente estas extensiones no son perjudiciales para nada, son complementos que tiene el apache

Entonces pues me gustaría saber si se puede configurar estas extensiones

Muchas Gracias!

#4
Solucionado
0
Hola.

Ahora que entiendo, la extensión .dll solo funcionan en Windows, nuestro servidor es Linux que usa la extensión .so. Pero veremos de darte una solución, queda a la espera mi respuesta.

Editado: Voy a tratar de instalar DOP y luego PDO_OCI que parece ser una aplicación más moderna del plugin OCI8. Necesito reconstruir primero Apache usando EasyApache, incluir DOP y luego tratar de instalar PDO_OCI a través de PECL.

Editado 2: Lamentablemente hay un error relacionado con DOP. Investigué un poco y se requiere las bibliotecas de Oracle.

Aquí está un poco más de información: https://bugs.php.net/bug.php?id=57351

Si nos da más data podriamos buscar otra forma.

Saludos!
Reglas de LagriHost | WIKI/Ayuda-FAQ | Nuestro Equipo | Solicita tu Hosting en 7 Pasos
No doy soporte por MP! Para eso esta el foro Guiño


[Imagen: banner-colabora.gif][Imagen: 8mt2wBp.jpg]

#5
Solucionado
0
Bueno si es para linux hay q instalar los siguientes drivers

oracle-instantclient11.2
oci8-2.0.8
PDO_OCI-1.0

Se deben instalar los tres para que funcione, El PDO no es un driver actualizado si no otro diferente para las consultas. pues se puede hacer con consultas normales o PDO

#6
Solucionado
0
(10-12-2014, 02:05 PM)jarcx9 escribió: Bueno si es para linux hay q instalar los siguientes drivers

oracle-instantclient11.2
oci8-2.0.8
PDO_OCI-1.0

Se deben instalar los tres para que funcione, El PDO no es un driver actualizado si no otro diferente para las consultas. pues se puede hacer con consultas normales o PDO

Excelente, trabajaremos en ello inmediatamente, te tendremos noticias por acá mismo.

Saludos!
- - - Actualizado - - -
No se puede descargar Oracle sin una cuenta, así que le agradeceremos si nos puede proporcionar el cliente instalable si posee una cuenta. Además de aclararnos estos puntos para poder instalarlo y evitar futuros problemas con la instalación (es primera vez que oimos de esta aplicación):

1) Una guía de instalación de este software para WHM/cPanel, servidor con Linux.

2) Guía y o URL específica para instalar este software, por ejemplo: http://www.mydomain.com o /home/mydomain/public_html

3) Si este software requiere un usuario administrador

4) Si este software requiere base de datos MySQL o usuarios creados

5) Si este software requiere licencia

Con esto nos podrá ayudar a instalarlo, y como le comenté primera vez que instalaremos esta aplicación externa, ya que antes no hacia falta pero igual siempre vemos de cumplir las necesidades de nuestros usuarios si esta en nuestras manos.

Saludos!
Reglas de LagriHost | WIKI/Ayuda-FAQ | Nuestro Equipo | Solicita tu Hosting en 7 Pasos
No doy soporte por MP! Para eso esta el foro Guiño


[Imagen: banner-colabora.gif][Imagen: 8mt2wBp.jpg]

#7
Solucionado
0
hola parce gracias por la colaboración

El software no requiere licencia, la como te habia comentado son librerías que ya vienen incluidas en PHP solo que cuando se instala en paquetes hay q activarlas, ps bien desabilitadas en el php.ini ejem (es como cuando uno tiene que habilitar digamos el mod rewrite para que funcione)

No requiere ni software ni mysql, como te comento es un modulo que existe por defecto en php solo hay q activarlo

No tengo guia como tal pues siempre lo manejo en windows y nunca he probado la instalación el linux, tengo estas referencias pero como te digo nunca he instalado



Muchas gracias por la atención brindada y esperemos se pueda instalar ya que en un servidor Linux es diferente

#8
Solucionado
0
Gracias por los enlaces, los voy a revisar, efectivamente nosotros estamos adaptados a Linux y en mi caso no he usado windows, muchas extensiones se activan fácilmente, esta parece que no xD

Ya te tendré noticias muy pronto Guiño
Reglas de LagriHost | WIKI/Ayuda-FAQ | Nuestro Equipo | Solicita tu Hosting en 7 Pasos
No doy soporte por MP! Para eso esta el foro Guiño


[Imagen: banner-colabora.gif][Imagen: 8mt2wBp.jpg]

#9
Solucionado
0
Espero se pueda  Estupendo  

Este es el php.info de mi servidor el cual tiene activado los modulos

[Imagen: BTOeoHi.png]

[Imagen: oV1e94T.png]



Parce muchas gracias!

#10
Solucionado
0
Estuve tratando pero no, parece que pecl necesita algo más para que funcione. Cuántos bits pide el oci8?
Reglas de LagriHost | WIKI/Ayuda-FAQ | Nuestro Equipo | Solicita tu Hosting en 7 Pasos
No doy soporte por MP! Para eso esta el foro Guiño


[Imagen: banner-colabora.gif][Imagen: 8mt2wBp.jpg]



Posibles temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Consulta como subo de plan de hosting panweb 0 73 03-07-2018, 11:24 AM
Último mensaje: panweb
Info Importante ¿Cómo solicito soporte técnico? Kevinex 1 2,048 17-10-2017, 11:19 PM
Último mensaje: Roberto
  Consulta Como solicito reactivacion de hosting grounterx 1 432 31-07-2017, 11:21 PM
Último mensaje: Kevinex
Post Como crear un sentencia en codigo PHP tayronv 0 603 11-11-2015, 07:34 PM
Último mensaje: tayronv
  Consulta ¿Cómo pagar para LedaHost? DarthAl 3 1,180 06-05-2015, 11:45 PM
Último mensaje: Kevinex



Usuarios navegando en este tema:
1 invitado(s)


Forum software by © MyBB Theme © Kevinex & iAndrew 2018